Start a new topic
Solved

Payments support for TLS 1.2 required by Braintree / PayPal

Hi we're using PayPal for payments.


May you confirm that it is using TLS 1.2? If not, when may we expect this to be supported?


Email from Braintree below

------------------------------------


Our records indicate that your production account sent requests through connections encrypted using TLS 1.0 and 1.1 in February 2018.

As part of PCI DSS 3.1, all merchants must update to TLS 1.2+. On June 26, 2018, Braintree will stop accepting connections encrypted using TLS 1.0 and 1.1 in order to meet the PCI DSS deadline of June 30, 2018.

If you do not update to TLS 1.2, you will no longer be able to interact with Braintree systems after June 26, 2018. This includes creating transactions, vaulting, and accessing the gateway. Learn how to ensure you're using TLS 1.2 here.

If you have already made this update, please disregard this email. If you have any questions about how these changes affect you, please reach out to our Support team by calling 877.434.2894 or emailing support@braintreepayments.com

1 Comment

Here is how to verify whether your server is compatible with TLS 1.2 or not:


$ php -f TlsCheck.php
PayPal_Connection_OK


.php file is attached.

php
(553 Bytes)
Login or Signup to post a comment